0%

Linux 下安装eclipse 及 perl 插件

虽然eclipse挺丑,但是还是挺好用的。 ## 一、安装java环境

由于eclipse需要java环境,所以首先在终端中输入java,看看是否已经安装。

如果未安装,输入apt-get insall default-jre 就会自行下载java,并配置好环境。

装好后可以输入java -version 看看版本号

java安装完后
java安装完后

二、下载解压eclipse

去eclipse官网下载eclipse,记得选Linux版本:

下载完后下载到你想安装的目录,用tar -xzvf命令解压,如图:

解压 tar -xzvf
解压 tar -xzvf

解压完成后,会在当前目录下多一个eclipse文件夹,输入./eclipse即可运行。

运行
运行

三、安装perl插件

(一)安装EPCI插件

打开eclipse,点击工具栏,help-> install new software

在弹出的窗口点击add如图,输入如图内容(Name可以随便写)

安装perl插件
安装perl插件

按ok之后选择EPIC main components 接下来一路next即可。

接下来一路Next
接下来一路Next

(二)安装PadWalker

刚才的EPIC只是让我们的eclipse支持perl,但是你可以尝试按下F11进行debugger,会发现提示不能显示变量值。此时需要安装PadWalker

终端中输入cpan,提示是否打开下载模式,输入y,之后输入install PadWalker  即可

如下图:

cpan
cpan

安装完这两个插件,就可以愉快的进行perl之旅啦~

安装完PadWalker
安装完PadWalker
请我喝杯咖啡吧~